扫一扫
关注微信公众号

OSPF路由协议配置指南
2008-07-18   51CTO

OSPF通过路由器之间通告网络接口的状态来建立链路状态数据库,生成最短路径树,每个OSPF路由器使用这些最短路径构造路由表。文档见RFC2178。
1、OSPF网络的特点是什么?ospf是一种链路状态路由协议,与距离矢量路由协议相对,它使用区域边界路由器和一个骨干区域,ospf定义的网络类型有:点到点、广播、非广播、点到多点等。
2、什么是区域边界路由器(ABR)?一个自治系统划分为多个区域,一个区域边界路由器连接同一个自治系统中的两个或者多个区域。
3、什么是骨干区域?骨干区域是一个与区域边界路由器相连接的区域,通常一个区域到另一个区域只能经过骨干区域。
4、ospf网络中有什么类型的路由器:骨干路由器、区域边界路由器、内部路由器、自治系统边界路由器(它连接两个自治系统)。
5 路由汇总:由区域边界路由器和自治系统边界路由器产生的路由的集合,它将向邻接的路由器通告。如果一个区域内的网络编号是连续的,那么区域边界路有器和自治系统边界路由器就能够被配置成通告路由,汇总路由指定了网络编号的范围。路由汇总减少了链接状态数据库的大小。
6 区域的类型:
短秃区域(stub):一种外部路由不流进的区域。所谓外部路由是指任何非ospf发起的路由,例如一条由其他路由协议发布的路由就是外部路由,外部路由通常在一个ospf互联网上泛洪式流过。如果一个区域只有一个出口,就几乎没有理由将大量路由流进该区域,只送一条缺省LSA路由到这个区域。通过该路由。短秃区域可以到达本自治区域以外的终端。
完全短秃区域。除了不将外部路由泛洪进该区域外,甚至连ospf概要路由也不进该区域。
7.有关csico路由器命令
全局设置

任务 命令
指定使用OSPF协议 router ospf process-id 1
指定与该路由器相连的网络 network address wildcard-mask area area-id 2
指定与该路由器相邻的节点地址 neighbor ip-address
注:
1、OSPF路由进程process-id必须指定范围在1-65535,多个OSPF进程可以在同一个路由器上配置,但最好不这样做。多个OSPF进程需要多个OSPF数据库的副本,必须运行多个最短路径算法的副本。process-id只在路由器内部起作用,不同路由器的 process-id可以不同。
2、wildcard-mask 是子网掩码的反码, 网络区域ID area-id在0-4294967295内的十进制数,也可以是带有IP地址格式的x.x.x.x。当网络区域ID为0或0.0.0.0时为主干域。不同网络区域的路由器通过主干域学习路由信息。
8.基本配置举例:

Router1:

interface ethernet 0
ip address 192.1.0.129 255.255.255.192
!
interface serial 0
ip address 192.200.10.5 255.255.255.252
!
router ospf 100
network 192.200.10.4 0.0.0.3 area 0
network 192.1.0.128 0.0.0.63 area 1
!
Router2:

interface ethernet 0
ip address 192.1.0.65 255.255.255.192
!
interface serial 0
ip address 192.200.10.6 255.255.255.252
!
router ospf 200
network 192.200.10.4 0.0.0.3 area 0
network 192.1.0.64 0.0.0.63 area 2
!
Router3:
interface ethernet 0
ip address 192.1.0.130 255.255.255.192
!
router ospf 300
network 192.1.0.128 0.0.0.63 area 1
!
Router4:
interface ethernet 0
ip address 192.1.0.66 255.255.255.192
!
router ospf 400
network 192.1.0.64 0.0.0.63 area 1
!
相关调试命令:

debug ip ospf events
debug ip ospf packet
show ip ospf
show ip ospf database
show ip ospf interface
show ip ospf neighbor
show ip route

#p#副标题#e#

9. 使用身份验证
为了安全的原因,我们可以在相同OSPF区域的路由器上启用身份验证的功能,只有经过身份验证的同一区域的路由器才能互相通告路由信息。
在默认情况下OSPF不使用区域验证。通过两种方法可启用身份验证功能,纯文本身份验证和消息摘要(md5)身份验证。纯文本身份验证传送的身份验证口令为纯文本,它会被网络探测器确定,所以不安全,不建议使用。而消息摘要(md5)身份验证在传输身份验证口令前,要对口令进行加密,所以一般建议使用此种方法进行身份验证。
使用身份验证时,区域内所有的路由器接口必须使用相同的身份验证方法。为起用身份验证,必须在路由器接口配置模式下,为区域的每个路由器接口配置口令。
任务
命令


指定身份验证
area area-id authentication [message-digest]
使用纯文本身份验证
ip ospf authentication-key password
使用消息摘要(md5)身份验证
ip ospf message-digest-key keyid md5 key
以下列举两种验证设置的示例,示例的网络分布及地址分配环境与以上基本配置举例相同,只是在Router1和Router2的区域0上使用了身份验证的功能。:
例1.使用纯文本身份验证
Router1:

interface ethernet 0
ip address 192.1.0.129 255.255.255.192
!
interface serial 0
ip address 192.200.10.5 255.255.255.252
ip ospf authentication-key cisco
!
router ospf 100
network 192.200.10.4 0.0.0.3 area 0
network 192.1.0.128 0.0.0.63 area 1
area 0 authentication
!
Router2:

interface ethernet 0
ip address 192.1.0.65 255.255.255.192
!
interface serial 0
ip address 192.200.10.6 255.255.255.252
ip ospf authentication-key cisco
!
router ospf 200
network 192.200.10.4 0.0.0.3 area 0
network 192.1.0.64 0.0.0.63 area 2
area 0 authentication
!
例2.消息摘要(md5)身份验证:
Router1:

interface ethernet 0
ip address 192.1.0.129 255.255.255.192
!
interface serial 0
ip address 192.200.10.5 255.255.255.252
ip ospf message-digest-key 1 md5 cisco
!
router ospf 100
network 192.200.10.4 0.0.0.3 area 0
network 192.1.0.128 0.0.0.63 area 1
area 0 authentication message-digest
!
Router2:

interface ethernet 0
ip address 192.1.0.65 255.255.255.192
!
interface serial 0
ip address 192.200.10.6 255.255.255.252
ip ospf message-digest-key 1 md5 cisco
!
router ospf 200
network 192.200.10.4 0.0.0.3 area 0
network 192.1.0.64 0.0.0.63 area 2
area 0 authentication message-digest
!
相关调试命令:

debug ip ospf adj
debug ip ospf events

热词搜索:

上一篇:用触发器生成数据库表的数据操作日志
下一篇:路由器路由协议安全配置

分享到: 收藏
评论内容